« 8月14日のトレーニング | トップページ | 基礎からのASP.NETを読む(9) »

2010年8月16日 (月)

Ruby on Rails勉強会に参加しました。

昨日、Ruby on Rails勉強会に参加してきました。

盆のど真ん中という日程でしたが、
15人程度の参加者がいました。

今回も私は書籍に従って、黙々とRailsを触っていたのですが、
今回はMac特有(?)のハマりポイントにハマってしまった
ようで、あまり進展がなかった感じがしました。

前回の書籍情報管理画面の作成から、ショップ画面の作成まで
進め、特にハマる事も無く、順調に進んだと思います。

で、ハマったポイントは、
rake db:migrateを実行した時に、RailsのVersionが1.3.1と認識されて
実行できない現象が発生しました。

MacにはデフォルトでインストールされているRubyと
MacPortsでインストールするRubyの2種類があり、
デフォルトのRubyとMacPortsのRubyのコマンドで不一致があった
ようで、古いバージョンだと認識されていたようです。
(結局、デフォルトのRubyをリネームして実行されないように変更した)

それから、rake db:migrateは一度実行するとVersionを覚えてしまうため、
2回目以降は実行されなくなるとの事で、db:migrate:upとかdb:migrate:down
を使って、再実行させるようです。

また、次回もできれば参加したいと思います。

|

« 8月14日のトレーニング | トップページ | 基礎からのASP.NETを読む(9) »

Ruby」カテゴリの記事

コメント

コメントを書く



(ウェブ上には掲載しません)




トラックバック

この記事のトラックバックURL:
http://app.cocolog-nifty.com/t/trackback/50625/49163122

この記事へのトラックバック一覧です: Ruby on Rails勉強会に参加しました。:

« 8月14日のトレーニング | トップページ | 基礎からのASP.NETを読む(9) »